Read time: 1 minute

Kemp's Bold-Faced Lie: AIDS Vaccine Mandates Failed! Huh?

Lying with no conscience is the cornerstone of the Republican Party.
Views:

Trying once again to deflect blame for his refusal to control the virus in his state, Georgia Governor Brian Kemp made as bogus an analogy as I've ever heard so far. On Erick Erickson's podcast, he lied about why people don't need a mandate to take the COVID vaccine.

"That is basically how the AIDS vaccine worked. People wouldn’t take it early on because it was mandated, they started educating people and now it is doing a lot of good out there," Kemp told Erickson. "Same scenario, different year that we are dealing with right now.”

Say what?

There never was an AIDS vaccine, let alone government mandates for all people to take it.

Brian Kemp even told Fox Business the same thing last week.

Gov. Kemp said, "Just like the AIDS vaccine, mandating it didn't work. It only worked when they started to educate people why it was a good idea."

Local 11alive news fact-checked Kemp's incredible lie.

According to HIV.gov - a website maintained by the U.S. Dept. of Health & Human Services - there currently is no vaccine for HIV, the virus that causes AIDS.

On the basic matter of there being an AIDS vaccine, which the governor has referenced at least two other times publicly, Kemp's statements are false.

Kemp's office claims he made a little mistake, confusing HPV (for which there IS a vaccine) with HIV, but he didn't. If you mistake an AIDS vaccine for HPV vaccine once, that's possible. But he made this claim multiple times.

It's a blatant attempt to confuse the issue as much as possible with a lie so big, it's beyond the realm of our reality. Lying is the norm for Republicans. In fact, it's their cornerstone.

Can you help us out?

For 17 years we have been exposing Washington lies and untangling media deceit, but now Facebook is drowning us in an ocean of right wing lies. Please give a one-time or recurring donation, or buy a year's subscription for an ad-free experience. Thank you.

More C&L Coverage

Discussion

New Commenting System

Our comments are now powered by Insticator. In order to comment you will need to create an Insticator account. The process is quick and simple. Please note that the ability to comment with a C&L site account is no longer available.

We welcome relevant, respectful comments. Any comments that are sexist or in any other way deemed hateful by our staff will be deleted and constitute grounds for a ban from posting on the site. Please refer to our Terms of Service (revised 3/17/2016) for information on our posting policy.

Please Do Not Use the Login Link at the Top of the Site.

In order to comment you must use an Insticator account. To register an account, enter your comment and click the post button. A dialog will then appear allowing you create your account.

We will be retiring our Crooks and Liars user account system in January, 2021.

Thank you.
C&L Team